Azure

Expand all | Collapse all

Cluster is not starting up

  • 1.  Cluster is not starting up

    Quboler
    Posted 09-06-2018 20:03
    Edited by Terry Martin 09-27-2018 13:01

    I have modified cluster settings for Azure on Qubole, but in the advanced configuration setting, I did not provide bastion node configuration. For customer SSH public key, we assign the SSH key value which we generated while creating Qubole Data Service on Azure. After making all these configuration changes, when we started the Hadoop Cluster, it went into terminated state.

    I have configured the Qubole Account settings for Azure, but in the compute setting section, when we select push compute setting to all clusters and click on save, it throws an error that the Hadoop Cluster is up. But when we are creating a table in hive, it throws an error that the cluster is not up and in the resources tab it shows that 'No resources are available for this query'.

    Here is the start-logs for hive query:
    Exception in start: Azure Error: AuthorizationFailed
    Message: The client 'xxxxxxxxxxx-xxx-xxxx-xxx-xxxxxxxxxxxxxxx' with object id 'xxxxxxxxxxx-xxx-xxxx-xxx-xxxxxxxxxxxxxxx' does not have authorization to perform action 'Microsoft.Resources/subscriptions/resourcegroups/write' over scope '/subscriptions/xxxxxxxx-xxx-xxxx-xxx-xxxxxxxx/resourcegroups/UsProdAzureqbol_acc225_cl752'.



    ------------------------------
    Urvashi Kohli
    ------------------------------


  • 2.  RE: Cluster is not starting up

    Posted 07-01-2019 03:35
    Hi Urvashi,
    Were you able to configure the Account Settings. I am facing the same blocker.

    Regards,
    Sloka

    ------------------------------
    Sloka Roy
    ------------------------------